ChannelAdvisor Support Phone System Issues
Incident Report for ChannelAdvisor Status Page
Resolved
This issue has been resolved. We sincerely apologize for any inconvenience this disruption may have caused.
Posted Feb 04, 2020 - 11:13 UTC
Investigating
Currently, ChannelAdvisor Support is experiencing intermittent inbound phone system issues. We are actively working with our provider to remedy the situation.

In the absence of calling directly, please contact the ChannelAdvisor Support team via My Support Center: https://community.channeladvisor.com/s/support-center
Posted Feb 03, 2020 - 19:46 UTC
This incident affected: System.