Amazon North America MFN Order Import Issues
Incident Report for ChannelAdvisor Status Page
Resolved
This issue has been resolved. At this time, all orders are importing normally.

There is no action required on the part of ChannelAdvisor clients.
Posted Jun 08, 2021 - 19:57 UTC
Investigating
Our Engineering team is currently investigating delays importing orders from Amazon in North America. We have
contacted Amazon and are awaiting additional information.
Impacted locales:
US
Canada
Mexico
Brazil

This alert will be updated as more information is available.
Posted Jun 08, 2021 - 17:42 UTC
This incident affected: Platform (Fulfill: Orders & Fulfillment).