Customer Care Center Access Issues
Incident Report for ChannelAdvisor Status Page
Resolved
This issue has been resolved. There is no action required on the part of ChannelAdvisor clients.
Posted Oct 13, 2021 - 12:35 UTC
Identified
The root cause of this issue has been identified and we are working to implement a fix at our highest priority.
This alert will be updated as more information is available.
Posted Oct 13, 2021 - 12:16 UTC
Investigating
We are currently investigating issues with users accessing the Customer Care Center portal. As a result, you may be unable to view your invoices and payments. We are working on a resolution as our highest priority. We apologize for the inconvenience.

This alert will be updated as soon as more information is available.
Posted Oct 12, 2021 - 17:01 UTC
This incident affected: System.