The issue related to UI data visibility delays has now been resolved. There is no action required on the part of Rithum clients.
Posted Feb 14, 2026 - 10:37 UTC
Investigating
Following recent maintenance activities, we are currently experiencing delays within the Rithum for Brands UI. Product Updates, Orders, and Fulfillment updates continue to be processed as expected. The impact is limited to UI delays, which may affect the timeliness of data visibility. We are working on a resolution as our highest priority. We apologize for the inconvenience. This alert will be updated as soon as more information is available.
Posted Feb 14, 2026 - 09:36 UTC
This incident affected: System and Platform (Fulfill: Orders & Fulfillment).